Help:Objects Tab: Difference between revisions

From TrainzOnline
Jump to navigationJump to search
Sourtoe (talk | contribs)
Add ability to search objects list.
Sourtoe (talk | contribs)
More edits to objects text
 
(11 intermediate revisions by the same user not shown)
Line 1: Line 1:
Two different types of object assets exist in Trainz: <b>object assets</b> and <b>spline assets</b>. Adding and manipulating these assets in Surveyor Mode (F1) is accomplished by clicking on the <b>Objects 'F3'</b> tab in the Surveyor Tools Menu. Tools for assets directly related to tracks are provided separately under the <b>Tracks 'F4'</b> tab as described in detail at <span class="plainlinks">[https://online.ts2009.com/mediaWiki/index.php/Help:Surveyor_Track_Tools Help: Track Tools]</span>.
Two different types of object assets exist in Trainz: <b>object assets</b> and <b>spline assets</b>. Adding and manipulating these assets in Surveyor Mode (F1) is accomplished by clicking on the <b>Objects 'F3'</b> tab in the Surveyor Tools Menu. Tools for assets directly related to tracks are provided separately under the <b>Tracks 'F4'</b> tab as described in detail at <span class="plainlinks">[https://online.ts2009.com/mediaWiki/index.php/Help:Surveyor_Track_Tools Help: Track Tools]</span>. Within the Objects Tools menu, two buttons at the top select between tools for "object assets" and tools for "spline object assets". These can be selected by typing 'o' or 's', but be careful as SHIFT-S will crash the program.  


== Objects ==
== Objects ==
Line 6: Line 6:
=== [[File:Object add.jpg]] Add Objects ===
=== [[File:Object add.jpg]] Add Objects ===
{{clear}}
{{clear}}
The default mode for the Objects Tab is <b>Add Objects 'A'</b>. The alphabetical list shown is all of the objects installed on your computer. Begin by scrolling through the list using the scroll bar or by clicking on the up or down arrows. The selected object (in yellow type in the window above the listing) shows as a rotating 3D object in the viewer window.  Check that you are in Add Object mode (or click on Add Object 'A') to select this mode. Click on the terrain and the selected object is placed wherever you click. You can repeat this multiple times to
The default mode for the Objects Tab is <b>Add Objects 'A'</b>. The alphabetical list shown is all of the objects installed on your computer. Begin by scrolling through the list using the scroll bar or by clicking on the up or down arrows. The selected object (in yellow type in the window above the listing) shows as a rotating 3D object in the viewer window.  Check that you are in Add Object mode (or click on Add Object 'A') to select this mode. Click on the terrain (LMB) and the selected object is placed wherever you click. You can repeat this multiple times to
add a number of the selected object over an area.  Objects are generally placed "correctly" with respect to the ground surface, but tools described below can be used to manipulate the object.
add a number of the selected object over an area.  Objects are generally placed "correctly" with respect to the ground surface, but tools described below can be used to manipulate the object.


You can also search the objects listing. Click on the window showing the current selected object (in yellow type), press delete, then type in your search term.  The list will move immediately to the best match for the search term. Since the search considers only the first match it finds, this method of finding an object is less than ideal.
You can also search the objects listing. Click on the window showing the current selected object (in yellow type), press delete, then type in your search term.  The list will move immediately to the best match for the search term. Since the search considers only the first match it finds, this method of finding an object is less than ideal.
In as much as your objects list is likely to become quite long and the search engine is not at all efficient, you may wish to create a personal <b>picklist</b> of the assets you use most frequently. See <span class="plainlinks">[https://online.ts2009.com/mediaWiki/index.php/How_to_Create_a_Picklist Create a Picklist]</span>.
=== [[File:Object move.jpg]] Move Object ===
=== [[File:Object move.jpg]] Move Object ===
{{clear}}
{{clear}}
Click on the Move Object (M) and Click and hold on
Select the the <b>Move Object 'M'</b> tool and click and hold on any object and then drag the object around the
any object and then drag the object around the
terrain to new positions.
terrain to new positions.
=== [[File:Reload page.jpg]] Rotate Object ===
=== [[File:Reload page.jpg]] Rotate Object ===
{{clear}}
{{clear}}
Click on the Rotate Object (R) and Click and hold
Select the <b>Rotate Object 'R'</b> tool and click and hold on an object while moving the mouse left and right to rotate the object. A display shows you the number
and move the mouse left and right to rotate the
objects. A display shows you the number
of degrees of rotation.
of degrees of rotation.
You can set objects to
 
“randomly rotate” or not by choosing the Randomly Rotate
You can set objects to “randomly rotate” or not by choosing the Randomly Rotate option in the Surveyor Options menu from the Main Menu.
option in the Surveyor Options menu from the Main Menu.
 
=== [[File:object get.jpg]] Get Object ===
=== [[File:object get.jpg]] Get Object ===
{{clear}}
{{clear}}
Click on the Get Object (G) tool and then Click
Select the <b>Get Object 'G'</b> tool and then click on an object on the terrain (route map). The object selected will appear in the selection window. Change the tool selectioin to <b>Add Object 'A'</b> and click on the terrain where you wish to place another copy of the selected object.
on an object already placed on the terrain.
 
The object selected now appears in the
selection window.
Change the mode to Add Object (A) and Click again
on the terrain where you wish to place another copy of the
newly selected object.
=== [[File:Area cancel.jpg]] Delete Object ===
=== [[File:Area cancel.jpg]] Delete Object ===
{{clear}}
{{clear}}
Select Delete Object (D) then Click to delete an
Select the <b>Delete Object 'D'</b> tool and click on an object to delete it. Should you delete a wrong object, type
object. Continue Clicking to delete a number
on <b>Undo (Ctrl-z)</b> on the keyboard to reverse the last action. Note that continuing to type Ctrl-z will move back throughg your previous actions, reversing them.  Thus "undo" enables backing off a number of edits if the results are not accomplishing what you intended.
of objects. If you click on the wrong object, click
 
on Undo (Ctrl-Z) to undo the last action and replace the last
deleted object.
=== [[File:Height adjust house.jpg]] Height Adjust ===
=== [[File:Height adjust house.jpg]] Height Adjust ===
{{clear}}
{{clear}}
Click on Height Adjust (H) to enable the adjustment of
Select the <b>Height Adjust 'H'</b> tool to enable adjustment of the height of any object. Click (LMB) and hold then move the mouse to move the object up or down. Holding the Ctrl key in conjunction with this move will adjust the object’s height in increments of 0.1 units and holding the Shift key will change the height by units of 0.05.
the height of any Object. Only objects which have
 
been designed to be height adjustable will allow you to adjust
Some objects have been designed to NOT be height adjustable.  These are typically object assets that have vertex links to connect to spline assets, such as train station platforms.  The height of these objects can be adjusted using the terrain height tool.
their height. S
 
Holding the Ctrl key in conjunction with this move will adjust
the object’s height in increments of 0.1 units and holding the
Shift key will change the height by units of 0.05.
=== [[File:Edit properties.jpg]] Edit Properties ===
=== [[File:Edit properties.jpg]] Edit Properties ===
Click on Edit Properties (N). Then Click on
Select the <b>Edit Properties 'P'</b> tool to open the object properties window for any object you then click on. Type a name in the small text window after "Name:". The primary use of the <b>Properties</b> window is to place a user name on a specific object. You may also select whether the name is to apply on the Route or just the Session layer. This name will appear in the <b>Map Display</b> if you have checked on "Named Objects" in the options list (see <b>Map Display Options</b> button in the upper left of the Surveyor screen). Some objects (signs, for example) will display this name in-game.
any object in your route. A menu will then open up
allowing you to edit the properties of the object.




= Spline =
= Splines =
Splines are generally long thin
Spline assets are long objects such as roads, power lines, fences, etc. A completed spline object has two “spline points” denoted by white, rotating circles at the ends. These spline points can be placed any distance apart by dragging one of the spline points across the terrain, stretching the object in the process.  Additional spline points can be added to the spline to bend it.
objects such as roads, power lines,
fences and rows of trees. They consist
of two or more “spline points” denoted
by white circles. These spline points
can be placed any distance apart and
the spline object is then “stretched”
between the spline points as you place
them on the route.
To enter Object Spline
mode, Click on
the large Spline Mode
(S) button at the top
left of the tab menu.


[[File:Objects2 advanced.jpg|400px|left]]
[[File:Objects2 advanced.jpg|400px|left]]
Line 75: Line 51:
=== [[File:Object add.jpg]] Add Spline ===
=== [[File:Object add.jpg]] Add Spline ===
{{clear}}
{{clear}}
Click on the terrain to anchor the first spline point, and
To create a spline, click on the <b>Add spline 'A'</b> button after selecting a desired spline asset from the listing of available splines. Click on the terrain to anchor the first spline point (called a <b>vertex</b>) and click again some distance away to place a second vertex. You will see white circles at each end of the
Click again some distance away to place the second
spline segment. These spline points or <b>vertices</b> establish grab points on a spline that may be selected for moving or adding to a spline. Thus, to extend the spline, click  on a vertex and drag, clicking once more nearby. Note that the created spline curves between each vertex. Holding down the Ctrl key will lay out multiple spline segments with a new vertex each time you hit the LMB. Release the Ctrl key before setting the last vertex to end the spline.
spline point. You will see white circles at each end of the
 
spline. These spline points determine the points of a spline
Splines recognize other splines as being of a certain type (roadways, for example) and will connect at a common vertex. Attempting to connect dissimilar types (or just laying another spline type nearby) will generate the error message: <font color='red'>"Error: Cannot attach to this vertex"</font>. You can avoid this error and lay two dissimilar splines close to one another by holding down the Shift key.  The Shift key prevents even compatible vertices from joining, so laying out a spline while holding the Shift key produces segments that are not joined to each other.
that may be selected or moved.
 
To extend the spline further, Click again on the last spline
point, then Click once more nearby to extend the spline.
Holding down the Ctrl key
then placing several spline points is another way. Release the Ctrl Key and
place your final spline point to anchor the spline in place
=== [[File:Object move.jpg]] Move Spline ===
=== [[File:Object move.jpg]] Move Spline ===
{{clear}}
{{clear}}
Select the Move
To move a spline object. select the <b>Move spline 'M'</b> tool and click (LMB) and hold on a vertex, then drag the spline point to a new location. Release the LMB to complete the move. 
Spline (M) tool and then Click and hold while dragging
To avoid a vertex from linking up to another, compatible vertex close by, hold the Shift key down while making the move.
the spline point to a new position. To set the spline poit at a specific location, hold the Shift key when placing it. This shortcut can be used to place spline on top of one another.
 
=== [[File:Split spline.jpg]] Split Spline ===
=== [[File:Split spline.jpg]] Split Spline ===
{{clear}}
{{clear}}
If a spline is already curved, you can split it into two
The <b>Split spline 'Q'</b> tool breaks the connection at a vertex, creating two independent sections. Click (LMB) on a non-end vertex to break a spline.  Because a spline will curve between vertices, this tool can be used to make corners, as in a fence line.
sections by using the Split Spline (Q) tool. Click on the middle spline (or any non-end
 
spline point) to separate them.
=== [[File:object get.jpg]] Get Spline ===
=== [[File:object get.jpg]] Get Spline ===
{{clear}}
{{clear}}
Line 111: Line 81:
section that is not an end section of a spline, the spline will
section that is not an end section of a spline, the spline will
be split into two splines.
be split into two splines.
=== [[File:Straighten spline.jpg]] Toggle Traffic ===
=== [[File:Straighten spline.jpg]] Toggle Traffic ===
Many roads will have vehicles travelling on them automatically, this can be seen while in Surveyor after placing the roads.
In the more recent versions of Trainz, turning traffic on or off on a route is accomplished in <b>Edit Environment</b> under the <b>Edit Menu</b> (second from left in the top menu bar). Select <b>Location</b> to open the <b>Environment - Location</b> window, where you can enable or disable traffic on your route. See <span class="plainlinks">[https://online.ts2009.com/mediaWiki/index.php/What_is_Toggle_Traffic%3F Toggle Traffic]</span>.
Clicking on Toggle Traffic turns all
 
traffic off on the roads.Clicking on the button again will have traffic resume.When toggling traffic
on and off, it affect all spline roads on your route.  
{{clear}}
{{clear}}
=== [[File:Edit properties.jpg]] Edit Properties ===
=== [[File:Edit properties.jpg]] Edit Properties ===
Click on Edit Properties (N). Then Click on
The <b> Edit Properties 'P'</b> tool can be used to name a spline and also specify layer (route or session) where the new name will apply. Click on
any object in your route. A menu will then open up
the spline object to see the name of the spline and edit the name as desired.  
allowing you to edit the properties of the object.
{{clear}}
{{clear}}


Line 162: Line 130:
Click on Remove Gradient and then Click on a spline section to remove the gradient between
Click on Remove Gradient and then Click on a spline section to remove the gradient between
two spline points.
two spline points.
=== [[File:Edit properties.jpg]] Edit Propertires ===
----
{{clear}}
----
This can be used to name the spline and also set its
layer.
 


Return To:
='''Trainz Wiki'''=
*[[Help:Surveyor_Tools|Surveyor Tools]]
<table cellpadding="4" bgcolor=#ffffff>
*[[Help:TRS2019_Surveyor|Surveyor]]
<tr valign="top">
*[[Help:TRS19|TRS19 Help Page]]
<td>[[file:TrainzWiki.png|link=]]</td>
<td>
<span style="font-size: 17px;">'''More Tutorials and Guides to Using Trainz'''</span><br>
*'''[[Help:Surveyor_Tools|Surveyor Tools]]'''
*'''[[Help:TRS2019_Surveyor|Surveyor]]'''
*'''[[Help:TRS19|TRS19 Help Pages]]'''
*'''[[HowTo|How-to Guides]]'''
</td>
</tr>
</table>
----


[[Category:Help|Surveyor Objects Tab]]
[[Category:Help|Surveyor Objects Tab]]

Latest revision as of 17:16, 4 October 2021

Two different types of object assets exist in Trainz: object assets and spline assets. Adding and manipulating these assets in Surveyor Mode (F1) is accomplished by clicking on the Objects 'F3' tab in the Surveyor Tools Menu. Tools for assets directly related to tracks are provided separately under the Tracks 'F4' tab as described in detail at Help: Track Tools. Within the Objects Tools menu, two buttons at the top select between tools for "object assets" and tools for "spline object assets". These can be selected by typing 'o' or 's', but be careful as SHIFT-S will crash the program.

Objects

Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127

Surveyor Menu on right shown
with Objects Tools selected.

Add Objects

The default mode for the Objects Tab is Add Objects 'A'. The alphabetical list shown is all of the objects installed on your computer. Begin by scrolling through the list using the scroll bar or by clicking on the up or down arrows. The selected object (in yellow type in the window above the listing) shows as a rotating 3D object in the viewer window. Check that you are in Add Object mode (or click on Add Object 'A') to select this mode. Click on the terrain (LMB) and the selected object is placed wherever you click. You can repeat this multiple times to add a number of the selected object over an area. Objects are generally placed "correctly" with respect to the ground surface, but tools described below can be used to manipulate the object.

You can also search the objects listing. Click on the window showing the current selected object (in yellow type), press delete, then type in your search term. The list will move immediately to the best match for the search term. Since the search considers only the first match it finds, this method of finding an object is less than ideal.

In as much as your objects list is likely to become quite long and the search engine is not at all efficient, you may wish to create a personal picklist of the assets you use most frequently. See Create a Picklist.

Move Object

Select the the Move Object 'M' tool and click and hold on any object and then drag the object around the terrain to new positions.

Rotate Object

Select the Rotate Object 'R' tool and click and hold on an object while moving the mouse left and right to rotate the object. A display shows you the number of degrees of rotation.

You can set objects to “randomly rotate” or not by choosing the Randomly Rotate option in the Surveyor Options menu from the Main Menu.

Get Object

Select the Get Object 'G' tool and then click on an object on the terrain (route map). The object selected will appear in the selection window. Change the tool selectioin to Add Object 'A' and click on the terrain where you wish to place another copy of the selected object.

Delete Object

Select the Delete Object 'D' tool and click on an object to delete it. Should you delete a wrong object, type on Undo (Ctrl-z) on the keyboard to reverse the last action. Note that continuing to type Ctrl-z will move back throughg your previous actions, reversing them. Thus "undo" enables backing off a number of edits if the results are not accomplishing what you intended.

Height Adjust

Select the Height Adjust 'H' tool to enable adjustment of the height of any object. Click (LMB) and hold then move the mouse to move the object up or down. Holding the Ctrl key in conjunction with this move will adjust the object’s height in increments of 0.1 units and holding the Shift key will change the height by units of 0.05.

Some objects have been designed to NOT be height adjustable. These are typically object assets that have vertex links to connect to spline assets, such as train station platforms. The height of these objects can be adjusted using the terrain height tool.

Edit Properties

Select the Edit Properties 'P' tool to open the object properties window for any object you then click on. Type a name in the small text window after "Name:". The primary use of the Properties window is to place a user name on a specific object. You may also select whether the name is to apply on the Route or just the Session layer. This name will appear in the Map Display if you have checked on "Named Objects" in the options list (see Map Display Options button in the upper left of the Surveyor screen). Some objects (signs, for example) will display this name in-game.


Splines

Spline assets are long objects such as roads, power lines, fences, etc. A completed spline object has two “spline points” denoted by white, rotating circles at the ends. These spline points can be placed any distance apart by dragging one of the spline points across the terrain, stretching the object in the process. Additional spline points can be added to the spline to bend it.

Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127

Add Spline

To create a spline, click on the Add spline 'A' button after selecting a desired spline asset from the listing of available splines. Click on the terrain to anchor the first spline point (called a vertex) and click again some distance away to place a second vertex. You will see white circles at each end of the spline segment. These spline points or vertices establish grab points on a spline that may be selected for moving or adding to a spline. Thus, to extend the spline, click on a vertex and drag, clicking once more nearby. Note that the created spline curves between each vertex. Holding down the Ctrl key will lay out multiple spline segments with a new vertex each time you hit the LMB. Release the Ctrl key before setting the last vertex to end the spline.

Splines recognize other splines as being of a certain type (roadways, for example) and will connect at a common vertex. Attempting to connect dissimilar types (or just laying another spline type nearby) will generate the error message: "Error: Cannot attach to this vertex". You can avoid this error and lay two dissimilar splines close to one another by holding down the Shift key. The Shift key prevents even compatible vertices from joining, so laying out a spline while holding the Shift key produces segments that are not joined to each other.

Move Spline

To move a spline object. select the Move spline 'M' tool and click (LMB) and hold on a vertex, then drag the spline point to a new location. Release the LMB to complete the move. To avoid a vertex from linking up to another, compatible vertex close by, hold the Shift key down while making the move.

Split Spline

The Split spline 'Q' tool breaks the connection at a vertex, creating two independent sections. Click (LMB) on a non-end vertex to break a spline. Because a spline will curve between vertices, this tool can be used to make corners, as in a fence line.

Get Spline

Click on the Get Spline (G) tool and then Click on a spline object already placed on the terrain. The spline object selected now will appear in the selection window. Change the mode to Add Spline (A) and Click again on the terrain where you wish to place the newly selected spline object.

Delete Spline

Click on Delete Spline (O) then click on a section of spline between two adjacent white circles to remove unwanted spline sections. If you delete a section that is not an end section of a spline, the spline will be split into two splines.

Toggle Traffic

In the more recent versions of Trainz, turning traffic on or off on a route is accomplished in Edit Environment under the Edit Menu (second from left in the top menu bar). Select Location to open the Environment - Location window, where you can enable or disable traffic on your route. See Toggle Traffic.

Edit Properties

The Edit Properties 'P' tool can be used to name a spline and also specify layer (route or session) where the new name will apply. Click on the spline object to see the name of the spline and edit the name as desired.

Advanced

Click on the Advanced Menu (Shift F3) to access even more tools. A drop down menu is then revealed.

Spline Height

The Spline Height (H) tool can be used to raise or lower the height of certain types of splines (for example catenaries or road bridges). Click on Spline Height then Click and hold on a spline point (the white circle) and drag the mouse forward or backwards.

Delete Spline Point

Click on Delete Spline Point (X) and then Click on a white spline circle to remove unwanted spline points. You cannot delete an end spline point, but you can delete the whole section using the Delete Spline (D) tool.

Insert Spline Point

Click on Insert Spline Point (I) then Click between two existing spline points. Notice that a new spline point is created.

Smooth Spline

Smooth Spline (S) levels the track between two spline points, bringing the land up or down to match the levelled spline.

Get Vertex Height

Click on the Get Vertex Height and Click on the highest spline point on your spline. The height is displayed in the Height Value box.

Apply Vertex Height

Click on Apply Vertex Height then Click on another spline point. The spline point is raised to the same height as you first vertex.

Remove Gradient

Click on Remove Gradient and then Click on a spline section to remove the gradient between two spline points.



Trainz Wiki

More Tutorials and Guides to Using Trainz