|
|
| Line 4,603: |
Line 4,603: |
| </tr> | | </tr> |
| </table> | | </table> |
| | | <br> |
| <table> | | <table> |
| <tr valign="top"> | | <tr valign="top"> |
| <td>[[image:DriverSARSave01.png|link=|alt=Save Driver Game]]</td> | | <td>[[image:DriverSARSave01.png|link=|alt=Save Driver Game]]</td> |
| <td>[[image:DriverSARSave02.png|link=|alt=Save Driver Game]]</td> | | <td>[[image:DriverSARSave02.png|link=|alt=Save Driver Game]]</td> |
| | </tr> |
| | </table> |
| | <br> |
| | <table width=1000 bgcolor=#000000 cellpadding=2> |
| | <tr valign="top"> |
| | <td> |
| | <table bgcolor=#ffffb0 cellpadding=2> |
| | <tr valign="top"> |
| | <td width=25>[[image:NotePad.PNG|link=]]</td> |
| | <td width=975><span style="font-size: 17px; font-weight: 700;">Notes:'''</span><br> |
| | ---- |
| | If you edit a '''Session''' and then start '''Driver''' without first saving your edits, then every save you make in '''Driver''' will save the '''Session''' and not the current '''Game'''. |
| | <table bgcolor=#ffffe0 cellpadding=2> |
| | <tr valign="top"> |
| | <td width=25>[[image:PencilTips.PNG|link=]]</td> |
| | <td>To avoid this always save your '''Session Edits''' before switching to '''Driver''' - you can use a different session name if you don't want to overwrite the original session. The '''Games''' that you save will be attached to the '''Session''' name you use.</td> |
| | </tr> |
| | </table> |
| | </td> |
| | </tr> |
| | </table> |
| | </td> |
| </tr> | | </tr> |
| </table> | | </table> |
| Line 4,614: |
Line 4,636: |
| <tr valign="top"> | | <tr valign="top"> |
| <td width=629><span id="skipLoadDriverGames"></span> | | <td width=629><span id="skipLoadDriverGames"></span> |
| | |
| =='''Loading Games'''== | | =='''Loading Games'''== |
| </td> | | </td> |
Revision as of 06:31, 13 September 2025
| The information in this Wiki Page applies to Trainz Plus, TRS22 and TRS19. This page is intended to provide you with an overview of the properties and features of Routes and Sessions when creating layouts for Trainz. More detailed descriptions of these various features plus instructions on getting you started with creating Routes and Sessions can be found in the Trainz Wiki How To Guides are provided at the end of this document. |
|
|
Workflow Diagrams

 |
| The virtual worlds that Trainz creates can be classified as:- |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
 |
Routes |
Routes are created in Surveyor and contain most (if not all) of what you will see in your virtual Trainz world. You can have many different routes, limited only by your storage space. They can be built to represent different geographical regions (real or imagined) and different periods of time (past, present, future). They also control the environment settings in your virtual world, such as your geographic location and altitude, the season of the year, lighting conditions and the weather. Each route can have multiple sessions.
 |
Sessions |
Sessions are also created in Surveyor but are designed to be run in Driver. They contain the instructions that will control your trains when they are operating in automatic or "AI" mode in your route. They also control the goods your trains will carry, load and unload at industries along the way. You can create different sessions for different aspects of your railway - freight, passenger, shunting or a mixture - or for different seasons of the year or times of the day. Sessions are where you can program the behaviour of objects in your virtual Trainz world. A session can also contain scenery items that are specific to a particular railway operation, season or time of day. Sessions also control the environment settings in your virtual world, such as lighting conditions and the weather. Each session can have multiple saved driver games.
 |
Games (or Driver Games, Driver Sessions, Saved Games) |
Games (also known as Driver Games, Driver Sessions, Saved Games) are created in Driver and save the "state of play" in a running session so you can restart it at the same point at a later time. They are optionally stamped with the date and time they were saved and the play duration. |
A route (also known as a "Layout") consists of most of what you will see on the screen when using Surveyor and Driver. Things such as the landform or terrain, most (if not all) of the scenery items, the ground textures, the effect layers (such as TurfFX and Clutter), plus some "environmental" features.
A route consists of two parts:- |
 |
Route Data and |
 |
Route Layers |
|
|
Route Data: |
 |
The Route Data stores all those features that are painted into a layout using a brush tool and all the Environmental Data including the World Origin (latitude, longitude, altitude) |
| The Route Data includes the Terrain, Textures, Effect Layers, Legacy Water and the Environmental features. |
| Route Data contains:- |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Landforms (Terrain) - baseboards and ground height |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Water height and spread for Legacy Water found in Surveyor Classic |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Ground Textures including the grid pattern which is a texture |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
TurfFX, Clutter, Water, Color - found in the Effects Layers (the Color Effect Layer is only available in Trainz Plus when using High Definition (HD)) |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Environmental Settings - World Origin (latitude, longitude, altitude), Water Surface (rough/calm/etc), Snow Altitude, Lighting (sun, ambient and water colours), Sky (clouds), Road Traffic (on/off), Date (day, month), Wind strength, Fog level, Weather (rain/fine/snow), Brightness level. You must edit and save the route for these settings to become part of the Route Data - see the Trainz Wiki page How to Use the Environment Tools for more details. |
|
Route Layers: |
 |
Route Layers are used to hold the scenery assets that you want to appear in all sessions created for the route |
| All scenery assets are held in layers. Route Layers (you can have many layers) give you a way of organising or grouping the assets displayed in your route. |
| Route Layers contain:- |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Track and Track Objects (such as signals, switches, bridges, tunnels, speed signs, etc) |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Most (or all) scenery items (e.g. buildings, trees, rocks, active industries/stations) and scenery splines (e.g. roads, fences, etc) |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Rolling Stock (including locos) - Note: It is strongly recommended that all rolling stock be placed into a Session Layer |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Lineside and Fixed Cameras |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Trackmarks, Triggers, Direction and Priority Marks |
|
 |
Scenery objects can also be stored in a session. This can cause confusion if you load a route without loading a session and find that some scenery items are "missing". See Loading an Existing Route below for how to deal with this situation. |
|
 |
A detailed description of Layers can be found on the Trainz Wiki Page:-
|
| The Main Menu screen is shown below. The first option (shown highlighted in the image) opens Driver/Surveyor with all its options including loading and creating a route. |
 |
 |
Notes:
|
|
| Steps: To Load or Create a Route:- |
 |
Left Click on the large Driver / Surveyor graphic shown highlighted in white in the image on the left |
|
|
In the Driver/Surveyor screen a strip of thumbnails of all the Routes, installed and as well as available as DLC, will be shown at the base of the screen. If there are too many to fit in the available space, just move the mouse pointer onto any thumbnail to reveal the scroll bar device as shown below.

|
| Left Click and Drag the scroll bar left or right to reveal the additional routes or use the Expand View button described below |
| The thumbnail images are colour coded. |
| Payware on DLC |
Must be purchased and downloaded, but some may be free - depending on your membership options. If you click a thumbnail with this colour a DOWNLOAD button will appear on the bottom right of the screen. If a price is included in the button then that is the purchase price (in $US) |
| Payware installed |
Already installed from the DLC. DLC items cannot be deleted. To remove them use the Uninstall option in the Content Store from the Launcher. You can reinstall them later without any additional cost |
| Installed |
Downloaded from the Download Station (DLS) or created by you. This includes any cloned DLC Routes and Sessions (see Cloning a Route/Session below) |
| Multiplayer |
For simultaneous development by multiple players. Special conditions apply |
Creating a New Route
|
 |
 |
|
|
|
|
| In both Surveyor Classic (also known as S1.0 or S10) and in Surveyor 2.0 (also known as S2.0 or S20) Left Click on CREATE ROUTE . This will start Trainz Surveyor and create a new blank route with a single baseboard using the Default settings which are usually those that were used when you last created and saved a route. The default settings may include a ground texture other than the grid pattern, for example - thick grass. |
Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127
Surveyor 2.0 screen shown |
|
 |
You can easily edit the route settings at any time after the route has been created.
| Steps: To edit the route details at any time:- |
 |
Open the Edit menu from the top menu in Surveyor and select the Edit Route... option
The keyboard shortcut is Ctrl + E |
|
 |
|
|
|
|
It is recommended that you enter some details before you click the icon to create the new route. A bare minimum is listed on the right that will save you some time and effort later, and you can always change them at any time. |
|
| Route name: |
Enter a name for your new Route (keep it simple but descriptive)
|
| Geographical region: |
Select a region from the drop down list |
|
|

A Left Click on the icon at the bottom right of the window will apply the new data settings to the single flat baseboard that you have just created.
A Left Click on the icon at the bottom right of the window will cancel the data entry and continue to use the default data settings (usually the settings entered for the last route you created) in the single flat baseboard currently on the screen.
 |
Notes: Baseboard Texture
|
When a baseboard is added it will be covered with the Default Ground Texture which is usually the last one that you used. Selecting a Region (Point 3 in the Notes: Route Options on the right) will set the ground texture to be used in every baseboard added to the new route. Some regions have a standard grid pattern as their default ground texture - look on the DLS for region assets with TRS19 Grid in their titles. You can change the selected Region and its ground texture as often as you like but this will also change other properties of the route as described on the right.
You can create your own Region with your preferred ground texture and other features - see the Trainz Wiki Page How to Create a Region Asset for the details |
|
|
 |
Notes: Route Options
|
 |
Enter a Route name for the route - keep it simple but as descriptive as possible (without writing an essay). This will be the first thing that users will see when looking for a route to download from the DLS. |
 |
Enter a Route description for the route. At the starting stage this is basically a "memory jogger" for you so a basic description would be sufficient but before you release the finished route (e.g. to the DLS) it should contain some critical information such as Trainz Plus only, "high detail assets used" and the source(s) of any non-DLS dependencies |
 |
Setting a Region sets some basic features of the route - such as its latitude (used to determine the season of the year), the altitude (in metres) of the first baseboard, the number and types of moving road vehicles (if any) and the side of the road they drive on, to name a few. If none of the installed regions are suitable you can download others from the DLS or create a region of your own - see the Trainz Wiki Page How to Create a Region Asset |
 |
Create a Route thumbnail image. At the starting stage this is less important but at some point, before the route is released, select a suitable camera view point and Left Click on the Set Thumbnail button. The thumbnail is an advertisement for the route and many potential users will judge the quality of your work by the thumbnail when deciding whether to download or not |
 |
The Working scale provides measurements that are comparable to model railroading dimensions, but the actual (physical) sizes of the layout and its assets are not altered or scaled down. It is only the Surveyor Ruler and its measurements that will be affected. The choices are between Real scale (which is the default), G scale (100m real scale = 4.4m G scale), HO scale (100m real scale = 1.1m HO scale) and many other options. |
 |
The Working units provides a choice between Metric (metres, kilometres) and Imperial (yards, miles) which only affects measurements used by rulers (in Surveyor 2.0 separate metric and imperial rulers are available), track distances and train speeds (km/h or mph).
Note that track speed signs are always locked at either metric (km/h) or imperial (mph) - there are separate speed signs available for each. The signs will not be altered by this selection but their values will be converted. So a track speed sign that is set at 40 mph, for example, will still be displayed as 40 but it will be read as 64.3 km/h in Driver if the Working Units have been set to metric. So it will be less confusing if you use speed signs that are in the same working units as your route, for example use a metric sign showing 65 km/h instead of an imperial sign showing 40 mph.
Altitudes are always measured and displayed using metric units (metres). |
 |
The Route Edit Detail in Trainz Plus only. This sets the minimum ground brush size when working with HD resolution. It can be swapped between the two settings at anytime when editing. See SD/HD Options below for more details |
 |
The Draw distance cap sets how far away from the camera that scenery objects will be drawn. A high setting, particularly the Disabled option (which means no draw distance cap), could affect the game performance, including the fps rate (frames per second), on some systems |
|
|
The Surveyor World View
|
 |
 |
|
|
|
|
Depending on the Route Editor settings and the version of Trainz you are using, you may see or be affected by the following factors:-
Baseboards and Grid Squares: |
|
|
In Surveyor Classic (S10)
In Surveyor 2.0 (S20)
Surveyor 2.0 or S20 is an alternative version of Surveyor found in TRS22PE and Trainz Plus. Surveyor Classic is also available as an option in both TRS22PE and Trainz Plus.
In Surveyor 2.0 there is no separate Topology Tools fly-out. A single Tools Palette replaces all the separate tools "fly-outs" found in the original Surveyor Classic. |
| The Marquee area, shown with a green border in the image below right, shows the positions where 3 new baseboards will be created to add to the existing baseboard. The Marquee area has a Context Menu icon as shown in the image. |
|
Left Click on the Context Menu icon or press the T key to open up the Marquee Context Menu.
|
| The main Marquee Baseboard Operations, as shown in the Marquee Context Menu above, are:- |
|
|
|
Default Baseboard Ground Texture
|
 |
 |
|
|
|
|
| When a new route is created or a new baseboard is added in both Surveyor Classic and Surveyor 2.0 it will be covered with the ground texture for the selected Region or the default texture/grid if no region has been set. This can be changed to a different texture (including to the standard TRS19/TRS22 grid pattern). |
 |
| Steps: To disable the current default ground texture (easiest method):- |
 |
open the Surveyor Display Menu |
 |
select the Ground option |
 |
select the Grid sub-option. This will use the current grid texture. |
|
|
| A more complex solution is to edit an existing Region or create one of your own to add your preferred ground texture (such as the standard TRS22 grid pattern) to each new route you create and every new baseboard that you add. |
 |
Notes:
The Baseboard Ground Texture, chosen from the Surveyor Display Menu or by specifying a Region, will become the default for every new route you create and every new baseboard you add, until you change it to something else.
|
|
 |
Information on creating and editing Region assets can be found on the Trainz Wiki at:-
|
Loading an Existing Route
|
 |
 |
|
|
|
|
| You must first find and select the route to load from those already installed. At the top of the Driver/Surveyor screen the route search options are shown as a set of buttons. |
| Type: |
ROUTES is the default selection. No need to change this. |
| Source: |
PURCHASED is the default selection, Click and change to MY CONTENT for a route you have created (or already modified) or to INSTALLED for one you have downloaded from the DLS. |
| Region: |
ALL is the default selection. You can select a particular geographic region if required and IF the route had a geographic region set when it was created. |
| Search: |
You can narrow down the list of routes by typing the first few letters of its name (e.g. SA) as shown in the image above. |
| This will produce a display of thumbnails at the bottom of the screen. |
| Left Click on the thumbnail for the route you want to load, then Left Click on the EDIT ROUTE button to load the route into Surveyor. |
 |
Notes: Routes and Sessions - An Endless Source of Confusion
|
|
Loading a Route Into Surveyor From Content Manager
|
 |
 |
|
|
|
|
| Trainz provides a shortcut that allows you to load an existing route directly into Surveyor for editing from Content Manager. |
 |
Steps: To load a route from Content Manager:-
 |
in Content Manager select the filter Routes & Sessions |
 |
select the route to be edited |
 |
Right Click to open the Command Menu |
 |
select Open..., then select Edit Asset in Surveyor
|
|
|
|
Loading After an Unexpected Shutdown
|
 |
 |
|
|
|
|
| The options you will see are:- |
| Use changes |
Use the edited/changed versions that are in the open database assets. Note: there is a possibility that these assets may have been damaged during the shutdown and may be corrupted |
| Revert changes |
Ignore the edited/changed versions and load the previous versions instead |
| Cancel |
Cancel the Load and return to the Surveyor/Driver menu screen |
| You could also use the Content Manager program (select Manage Content from the Trainz Launcher) to Submit the open route or route and session assets. This has the risk of replacing the last good copy of that asset or assets with a possibly faulty copy. |
|
Editing a Route
|
 |
 |
|
|
|
|
 |
When a Route is loaded or a new Route is created all the assets you add will be automatically placed into a Route Layer |
When you create a new route, or load an existing route without a session, and start adding scenery assets they will automatically be placed into a Route Layer. See How to Use Layers for more details.
Any ground textures, effect layers (e.g. TurfFX, Water, Clutter) you add, or terrain changes (including new baseboards) you make, will be added to the Route Data. |
 |
WARNING: Do not edit track in a Route that is occupied by consists in any of the Sessions based on the Route
Moving or deleting a section of track in a Route that is occupied by a consist in a Session can cause the consist to become a "missing asset". This can happen if you load the Route only and not the Session. If a consist becomes a "missing asset" then the only immediate solution is to use the Delete missing assets command from the Tools menu in Surveyor.
Prevention:
if you have the consists placed in a Session then always load the Session, not just the Route, and move or delete any consists BEFORE editing the track they are occupying.
|
|
 |
You can edit the Route Characteristics at any time by selecting the Edit Route... option from the Edit Menu OR simply by pressing the Ctrl + E keys.
This will bring up the Edit Route dialogue window (shown below). |
|
|
 |
Route Characteristics:-
|
|
|
 |
 |
Route name . Editing this will change the route username in the config.txt file but it will not alter the route <kuid> value |
 |
Route description . Edit to include additional information or describe changes that have been made |
 |
Region . Changing the region (the Geographic region) selected could affect other features such as the moving road traffic, season of the year (through the latitude tag) and altitude |
 |
Route thumbnail . Left Click on the Set Thumbnail button to take a snapshot using the current camera view which will be used as the new thumbnail. The image shown in the example on the left has been edited. |
 |
Working scale . Changing this will only affect the measurement shown in the Surveyor Ruler tool |
 |
Working units . Switching between Metric and Imperial will change how train speeds are calculated and displayed in Driver (in km/h or mph) and the units used by track speed signs |
 |
Route Edit Detail in Trainz Plus only. This sets the minimum ground brush size when working with HD resolution. It can be swapped between the two settings at anytime when editing. See SD/HD Options below for more details |
|
 |
Draw distance cap will affect how far away from the camera that scenery objects will be drawn. A high setting, particularly the Disabled option (which means no draw distance cap), could affect the game performance, including the fps rate (frames per second), on some systems |
 |
Left Click on the icon to save the entered values and exit back to Surveyor. Left Click on the icon to cancel any entered values and exit back to Surveyor |
|
| SD/HD Options |
 |
| The Surveyor Route Editor will allow you to switch between two minimum brush sizes when working with HD resolution routes. |
| This option, available in Trainz Plus only, allows you to set the brush detail to the default HD (High Definition) or to a lower SD (Standard Definition) which is easier to work with over larger areas.
|
Adding Terrain Height, Textures, Effect Layers in a Route
|
 |
 |
|
|
|
|
 |
Terrain, Textures, Effect Layers can only be added to a route not a session |
 |
The height of the terrain can be adjusted to represent hills, valleys, plains, slopes |
 |
The Terrain can be painted with textures to represent real ground surfaces |
 |
Effect Layers (grasses, rocks, water, etc) can be added to the terrain to enhance its appearence. The types of effect layers that are available will depend on your Trainz version, GPU and Operating System |
In Surveyor Classic (S10)
| In Surveyor Classic (S10) the tools and objects are in tabbed icons on the right of the screen which can be opened by a Left Click on the icon or by pressing its Function Key |
 |
F1 |
The Terrain Height, Legacy Water and Effect Layers are added and manipulated by tools in the Topology icon (the F1 key). For the Effect Layers you will also need to open the Advanced tab |
 |
F2 |
The Ground Texture is added and manipulated by tools in the Paint icon (the F2 key) |
| Opening each tool will reveal a selection list of assets and/or a set of tools for applying and manipulating the selected feature |
|
In Surveyor 2.0 (S20)
| In Surveyor 2.0 (S20) there is a single set of common tools that can add and manipulate objects of any type. Select a tool by a Left Click on its icon in the Tools Palette or by pressing its key. You can also select multiple objects, that can be of different types, and manipulate them (move, rotate, delete) as if they were a single object. |
 |
W |
The Brush Tool in the Tools Palette sets the Terrain Height, paints the Ground Textures and adds/edits Effect Layers (including Water). The textures and effect layers are selected using the Filter Palette and the Assets Palette |
There is a Wiki Page that covers in great detail the use of the Surveyor 2.0 tools at How to Use S20 Tools with specific sections dealing with Ground Height, Ground Terrain and Effect Layers |
|
 |
Effect Layers |
|
|
|
Adding Assets to a Route
|
 |
 |
|
|
|
|
 |
Assets include all visible objects (trees, buildings, roads, tracks, signals, rolling stock, etc) and invisible objects (track triggers, track marks, etc) that can be added to your route |
 |
Objects added to your route will be present in all sessions created using that route |
In Surveyor Classic (S10)
| In Surveyor Classic (S10) the tools and objects are in tabbed icons on the right of the screen which can be opened by a Left Click on the icon or by pressing its Function Key. |
 |
F3 |
Scenery objects (e.g. buildings) and splines (e.g. roads) are added and manipulated by tools in the Objects icon (the F3 key) |
 |
F4 |
Railroad tracks and track objects (e.g. signals, switches, etc) are added and manipulated by tools in the Tracks icon (the F4 key) |
 |
F7 |
Rolling stock (locomotives, wagons) are added and manipulated by tools in the Trains icon (the F7 key) |
| Opening each tool will reveal a selection list of assets and a set of tools for applying and manipulating the selected asset |
|
In Surveyor 2.0 (S20)
| In Surveyor 2.0 (S20) there is a single set of common tools that can add and manipulate objects of any type. Select a tool by a Left Click on its icon in the Tools Palette or by pressing its key. You can also select multiple objects, that can be of different types, and manipulate them (move, rotate, delete) as if they were a single object. |
 |
E |
The Placement Tool adds ALL objects (scenery, splines, track and track objects, rolling stock) selected using the Filter Palette and the Assets Palette |
 |
S |
The Free Move Tool moves ALL objects, either individually or as a group, to anywhere on the surface |
 |
D |
The Fine Adjustment Tool moves and rotates ALL objects, either individually or as a group, in small movements to anywhere on, below or above the surface |
There is a Wiki Page that covers in great detail the use of the Surveyor 2.0 tools at How to Use S20 Tools |
|
Editing the Environment of a Route
|
 |
 |
|
|
|
|
 |
Notes:
It is possible (and sometimes even expected) that a Route and its Sessions will have different environmental settings - for example the Route may have been created for the summer season but one Session may be set in winter and will require an overcast sky, snow, fog and generally lower light levels. See the Trainz Wiki Page at The Environment Tools for more details.
|
|
|
|
Edit Effect Layers
|
 |
 |
|
|
|
|
 |
The Edit Effect Layers menu option allows you to add, remove and edit the special effect layers |
Merging Routes
 |
Two (or more) separate routes can be joined together (merged) to create a new route |
| There are some important restrictions on the merging of two routes:- |
 |
A detailed description of the process of Merging Routes can be found on the Trainz Wiki Page:-
|
 |
A Session is always a part of an existing Route - you cannot have a Session that does not belong to a Route |
 |
If you create a Route without a Session then ALL the active industries and rolling stock, time, environmental conditions, etc, will revert to their original (default) values. There will be no AI drivers and drivers will have a very limited set of available commands for manual driving |
In general, while a route provides the physical structures (or "hardware"), a session provides the services (or "software"). While you can easily have a route without a session, it could be a very limited (or even a boring) experience.
A single route can have multiple sessions, or none, but a session must always belong to a route. To put it into Trainz terminology, a session has a route as a dependency.
A session consists of two parts:-
|
 |
Session Data and |
 |
Session Layers |
|
|
Session Data:
| Session Data are often the "invisibles" that control the operation of a session. Session rules, driver orders and loco assignments, commodities (loaded, unloaded and carried) and most of the Environmental Settings are examples of Session Data. |
| Session Data contains:- |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Drivers (names, AI commands and assigned locos) |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Driver Commands - those available for AI and manual driving |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Session Rules |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Industry Settings (commodities consumed and produced) |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Consist Settings (commodities carried) |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Consist Locations - this is stored in the session even if the consists are placed in the route |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Switch Settings (left/right) - but the default switch direction is stored in the route. See Setting Switch Directions in Routes and Sessions for more information on this |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Environmental Settings - Water Surface (rough/calm/etc), Snow Altitude, Lighting (sun, ambient and water colours), Sky (clouds), Road Traffic (on/off), Date (day, month), Wind strength, Fog level, Weather (rain/fine/snow), Brightness level. You must edit and save the session for these settings to become part of the Session Data - see How to Use Environment Tools for more details. If both a route and a session have saved Environmental Settings, which do not have to be the same, then those in the session will be used. If the session does not have any saved Environmental Settings then those in the route will be used
|
|
Session Layers:
 |
Session Layers are used to hold the scenery assets that you want to only appear in that particular Session and not in all Sessions. The Session Layers can be left empty and the Route Layers can contain all the scenery assets |
Session Layers give you a way of organising or grouping the assets displayed in your session.
| Session Layers can contain any assets that will be unique to that Session:- |
|
|
|
|
 |
WARNING:
While it is possible to add track and track objects (bridges, tunnels, turntables, signals, switches, etc) to Session Layers it is NOT RECOMMENDED. These assets should always be placed into Route Layers Group and, preferably, into the route-layer itself. |
|
|
 |
A detailed description of Layers can be found on the Trainz Wiki Page:-
|
 |
Notes:
Scenery, Rolling Stock, Triggers and Markers (Track, Direction, Priority) can be used in both Route Layers and Session Layers. Assets placed in a Route Layer will appear in all sessions that are based on the route. The vast majority of (if not all) scenery items will be placed in Route Layers. Assets placed in a Session Layer will only appear in the currently loaded session.
Examples of assets that would be placed in a Session Layer instead of a Route Layer would include:-
|
|
Creating a New Session
 |
To create a new Session you must first create a new Route or load an existing Route |
 |
A route can have many individual sessions so a new session can be added to a route that already has sessions |
|
| Steps: To add a new session to an existing route:- |
 |
Locate (but do not load) the route as described in the section Loading an Existing Route above |
 |
Once you have selected the route from its thumbnail, Left Click on the VIEW SESSIONS button
 |
 |
Then Left Click on the CREATE SESSION button. If no other session exists for this route then this will be the only choice available to you
 |
|
Loading an Existing Session
|
 |
 |
|
|
|
|
There are two different ways to load existing sessions into Surveyor.
 |
Search For the Session |
|
The easiest way to load an existing session is to use the search tools at the top of the Driver/Surveyor screen.
 |
| Type: |
ROUTES is the default selection. Left Click on the button to change it to SESSIONS . |
| Source: |
PURCHASED is the default selection, Left Click on the button to change it to MY CONTENT for a session you have created (or already modified) or to INSTALLED for one you have downloaded from the DLS. |
| Gameplay: |
ALL is the default selection. There is no need to change this |
| Search: |
If required you can narrow down the list of sessions by typing the first few letters of its name. |
|
 |
Notes:
|
|
|
This will produce a list of session thumbnails at the bottom of the screen. As with the route thumbnails, the list can be scrolled horizontally.
The same colour coding system used in the route thumbnails also applies to session thumbnails.
| Payware on DLC |
Must be purchased and downloaded, but some may be free - depending on your membership options. If you click a thumbnail with this colour a DOWNLOAD button will appear on the bottom right of the screen. If a price is included in the button then that is the purchase price (in $US) |
| Payware installed |
Already installed from the DLC. DLC items cannot be deleted. To remove them use the Uninstall option in the Content Store from the Launcher. You can reinstall them later without any additional cost |
| Installed |
Downloaded from the Download Station (DLS) or created by you. This includes any cloned DLC Routes and Sessions (see Cloning a Route/Session below) |
| Multiplayer |
For simultaneous development by multiple players. Special conditions apply |
Left Click on the thumbnail for the session you want to load and then Left Click on the EDIT SESSION button. This will load BOTH the route and the session into Surveyor.
 |
If the EDIT SESSION option is not present then the selected session is a saved Game (a "game" saved when in Driver) and cannot be edited. See the section Loading Games below.
|
|
|
 |
Select the Route First |
|
|
 |
If the EDIT SESSION option is not present then the selected session is a saved Game (a "game" saved when in Driver) and cannot be edited. See the section Loading Games below.
|
|
|
|
Both and will load the route and session into Surveyor. |
Loading a Session Into Surveyor From Content Manager
|
 |
 |
|
|
|
|
Trainz provides a shortcut that allows you to load an existing session directly into Surveyor for editing from Content Manager.
 |
Steps: To load a session into Surveyor:-
 |
in Content Manager select the filter Routes & Sessions |
 |
select the session to be loaded and edited in Surveyor |
 |
Right Click to open the Command Menu |
 |
select Open... , then select Edit Asset in Surveyor |
Both the route and the session will be loaded into Surveyor for editing. |
|
|
Loading a Session into Driver From Surveyor
|
 |
 |
|
|
|
|
To start Driver simply select a session as described above in Loading an Existing Session and Left Click on the DRIVE SESSION button.

This will load both the session and the route into Driver.
You can save your "game play" in Driver at anytime. See
Loading Games below.
Loading a Session into Driver From Content Manager
|
 |
 |
|
|
|
|
Trainz provides a shortcut that allows you to load an existing session directly into Driver from Content Manager.
Editing a Session
|
 |
 |
|
|
|
|
 |
WARNING:
When a Session is loaded into Surveyor or a new Session is created all the assets you add will be AUTOMATICALLY placed into a Session Layer. To place them in a different layer, for example a Route Layer, change the Active Layer to the required layer before adding them to the route. See the Trainz Wiki Page How to Use Layers for more details. |
|
Any changes made to the Session Rules (including drivers and their commands), the Environment Tools, Industry or Rolling Stock settings, will be added to the Session Data.
There are other changes that will also be added to the Session Data. |
 |
|
 |
You can edit the Name of the Session. This will change the session username in the config.txt file but it will not alter the session <kuid> value |
 |
You can edit the Session Description |
 |
You can add, delete and edit the Session Rules |
|
Adding Assets to a Session
|
 |
 |
|
|
|
|
 |
Assets include all visible objects (trees, buildings, roads, tracks, signals, rolling stock, etc) and invisible objects (track triggers, track marks, etc) that can be added to your session |
 |
Any objects added to a session will only be available in that session |
In Surveyor Classic (S10)
| In Surveyor Classic (S10) the tools and objects are in tabbed icons on the right of the screen which can be opened by a Left Click on the icon or by pressing its Function Key |
 |
F3 |
Scenery objects (e.g. buildings) and splines (e.g. roads) are added and manipulated by tools in the Objects icon (the F3 key) |
 |
F4 |
Railroad tracks and track objects (e.g. signals, switches, etc) are added and manipulated by tools in the Tracks icon (the F4 key) |
 |
F7 |
Rolling stock (locomotives, wagons) are added and manipulated by tools in the Trains icon (the F7 key) |
| Opening each tool will reveal a selection list of assets and a set of tools for applying and manipulating the selected asset |
|
In Surveyor 2.0 (S20)
| In Surveyor 2.0 (S20) there is a single set of common tools that can add and manipulate objects of any type. Select a tool by a Left Click on its icon in the Tools Palette or by pressing its key. You can also select multiple objects, that can be of different types, and manipulate them (move, rotate, delete) as if they were a single object. |
 |
E |
The Placement Tool adds ALL objects (scenery, splines, track and track objects, rolling stock) selected using the Filter Palette and the Assets Palette |
 |
S |
The Free Move Tool moves ALL objects, either individually or as a group, to anywhere on the surface |
 |
D |
The Fine Adjustment Tool moves and rotates ALL objects, either individually or as a group, in small movements to anywhere on, below or above the surface |
There is a Wiki Page that covers in great detail the use of the Surveyor 2.0 tools at How to Use S20 Tools |
|
Editing the Environment of a Session
|
 |
 |
|
|
|
|
 |
Environmental settings in a Session will have priotity over those in a Route |
Routes and Sessions are saved from the System Menu on the Surveyor screen.
 |
Notes on Saving DLS/DLC Routes and Sessions:
|
| |
| DLS Routes and Sessions can be modified and saved as new routes and sessions |
 |
Modifying and Creating:-
|
 |
Saving:-
|
 |
Uploading:-
|
|
| |
DLC Routes and Sessions can also be modified and saved as new routes and sessions ONLY if the creators of the original DLC content have allowed it - see Cloning a Route/Session below for more details |
 |
Modifying and Creating:-
|
 |
Saving:-
|
 |
Uploading:-
|
|
Saving a New Route and Session
|
 |
 |
|
|
|
|
If you have created a new route and select Save or Save As..., then you will be presented with the following Save Route Dialogue Windows.
 |
 |
| In both cases the name of the route that was entered when it was created will be shown and you can change the name, even in the Save option. However, there is no option in either case to change the name of the created session because the other options have been greyed out and cannot be selected. |
Saving an Existing Route
|
 |
 |
|
|
|
|
| If you have loaded the route only and not the session and HAVE NOT edited any Session Data or Session Layers, then selecting Save will produce the following Save Route Dialogue Window. |
| If you have loaded the route only and not the session and HAVE edited Session Data or Session Layers, then selecting Save will produce the following Save Route Dialogue Window. |
Saving an Existing Route and Session
|
 |
 |
|
|
|
|
| If you have loaded a route and a session and have edited the route OR both the route AND the session, then selecting Save will produce the following Save Route Dialogue Window. |
Saving an Edited Session Only
|
 |
 |
|
|
|
|
 |
If you have only edited the session then you will be given the option to save the Session only |
| If you have loaded a route and a session and have edited the session (Data or Layers) only and not the route, or have already saved the route but not the session, then selecting Save will produce the following Save Session Dialogue Window. |
Saving a Route and Session Using the UDS
|
 |
 |
|
|
|
|
 |
The UDS feature is available in TRS19 Platinum Edition, Trainz Plus, TRS22 and TRS22 Platinum |
| The UDS (Unified Driver Surveyor) Interface allows you to quickly switch from Driver to Surveyor and back to Driver again without having to restart the session from the beginning. You can edit a route and session while in Surveyor and then switch back to Driver to continue the session where you left it. |
 |
WARNING:
This powerful ability does come with a warning. If you save the edited session before switching back into Driver then all the moving consists will be saved in their new positions. Other changes, such as the status of Session Rules, will also be saved in their new states. See the Trainz Wiki Page How to Use the UDS Interface for more details.
|
|
| Most of the problems users seem to be experiencing with the UDS, judging from the posts in the Trainz Forums, is when saving their edited Driver session after switching to Surveyor mode. |
Unless you have a particular reason for overwriting the original Session then the recommended save options are:-
|
If you have NOT edited anything while in Surveyor and select Save then you will be shown the Save Driver Session dialogue window to save the session in its current state as a Game (also called a Driver Game). This is exactly the same as pressing Ctrl + S while in Driver.

The Game will appear in the Select Session menu for the route. Loading it will resume Driver at the point where it was saved. |
 |
If you exit Surveyor after editing without saving then you will be prompted to Save. |
 |
Steps:
 |
Open the Main Menu |
 |
select the Exit Surveyor option |
| Another option is to exit Trainz completely |
 |
select the Exit Game option |
| Regardless of which option you take, if you have unsaved work you will be prompted to save before you exit |
|
|
|
| Unsaved Route |
Unsaved Session |
 |
 |
| Options: |
 |
Don't Save will exit Surveyor to either the Main Menu Screen or to your OS Desktop without saving. Any changes you have made will be lost. |
 |
Save will exit Surveyor to either the Main Menu Screen or to your OS Desktop after saving. You will be prompted to select what to save as described in the section Saving a Route and a Session above |
 |
Cancel will cancel the Exit command and return you to Surveyor. |
|
 |
If you exit Driver after running a session you will be prompted to Save the current Game |
 |
Steps:
 |
Open the Main Menu |
 |
select the Exit Driver option |
| Another option is to exit Trainz completely |
 |
select the Exit Game option |
| Regardless of which option you take, if your Session Data has changed then you will be prompted to save before you exit |
|
|
|

| Options: |
 |
Don't Save will exit Driver to either the Main Menu Screen or to your OS Desktop without saving. The current state of the session (positions and movements of the consists, commodity levels, time of day, etc) will be lost. |
 |
Save will exit Driver to either the Main Menu Screen or to your OS Desktop sfter saving. You will be prompted to enter a name for your saved Game. See the section Saving Games below for more details. |
 |
Cancel will cancel the Exit command and return you to Driver. |
|
 |
A Clone is an exact or duplicate copy of an asset. Some Payware routes and sessions cannot be cloned |
 |
Cloned routes and sessions can be edited and saved as Your Content |
| Cloning a Route or a Session allows you to work on a duplicate copy of the original. All changes that you make will be saved in the cloned copy leaving the original copy unchanged. |
 |
Cloned assets are subject to copyright laws and they remain the property of the original creator
|
|
 |
Notes:
|
 |
Freeware routes, that have been downloaded and installed from the DLS, can be cloned and saved as new routes.
|
 |
Payware Routes, that have been downloaded and installed from the DLC, can also be cloned as new routes if the creators of the routes allow it.
|
 |
Sessions that have been downloaded and installed from the DLS (freeware) or DLC (payware) follow the same rules as described for DLS and DLC routes above
|
|
Cloning Using Surveyor
|
 |
 |
|
|
|
|
| Routes and Sessions that have been loaded into Surveyor can be cloned using the Save As... command from the Surveyor System Menu |
| Enter a new name or edit the original name (as shown above) for your cloned route or session. |
| Options: |
 |
If the first option ( Save new route and session) is selected then the Route will be cloned using your new or edited name. The Session will be also cloned using its original name but it will use the newly cloned Route as a dependency instead of the original Route.
|
 |
If the second option ( Save new session) is selected then only the Session will be cloned using your new or edited name (make sure that you change the "Default" to something else) but it will still use the original (uncloned) Route as a dependency - so it is vital that you DO NOT DELETE the original route.
|
|
Cloning Using Content Manager
|
 |
 |
|
|
|
|
Select the Route or Session to Clone |
A Task Window will open to display the result.

In the image above the original Route has been cloned and given a new <kuid> value.
The newly cloned Route will be shown in Content Manager as a New Asset that is Open for Editing. |
Steps:
 |
close the Task Window |
 |
select the Open for Editing filter. |
|
|
Rename the Clone (an Optional Step)
You can give the cloned Route or Session a new name and a new description. Note that these changes will not appear until after the New Asset has been submitted. |
Submit the Clone (a Necessary Step) |
 |
When submitted a cloned DLC Route or Session will be described as Payware, Modified while a cloned DLS Route or Session will be described as Modified |
Steps:
 |
Right Click on the New Asset |
 |
select the option Submit Edits |
The New Asset entry will vanish from the Open for Editing display. Open the Content Manager filter Today to check that it has been correctly submitted. If you have renamed the clone then it should appear using its new name.
|
|
 |
Notes:
You can rename a cloned Route or a cloned Session in Surveyor but the clone would still have to be submitted in Content Manager first using its original name and then loaded into Surveyor. You would then have two Routes or Sessions with the same name to select from - one would be the original and the other the clone, and telling them apart may not be simple. You can use the Driver/Surveyor main screen MY CONTENT source filter to locate and load the correct cloned Route or Session because the clone will have your <kuid> code and not its original code.
 |
Load the cloned Route or Session into Surveyor, then
Both will also allow you to edit the Name and Description of the cloned Route/Session.
|
|
|
 |
Games (sometimes called "Saved Games" or "Driver Games") are "Game States" saved while in Driver Mode |
 |
Notes:
|
|
Saving Games
|
 |
 |
|
|
|
|
Games save the "state of play" in Driver. Once saved, the Game can be loaded back into Driver to continue the play at the point where it was saved.
The Game will be saved with:-
When you are in Driver select Save from the System Menu or press Ctrl + S .
This will display the Save Driver Session dialogue window showing the name of the current session with a date and time stamp (shown left below). If you Left Click on the icon then this will be the name used for the saved game. Alternatively, you could enter your own unique name (shown right below) and then Left Click on the icon.
The space below the entered name will display any other saved driver games for that session. |
 |
 |
 |
 |
Notes:
If you edit a Session and then start Driver without first saving your edits, then every save you make in Driver will save the Session and not the current Game.
 |
To avoid this always save your Session Edits before switching to Driver - you can use a different session name if you don't want to overwrite the original session. The Games that you save will be attached to the Session name you use. |
|
|
Loading Games
|
 |
 |
|
|
|
|

Where there is only one session in a route, the session will be the first thumbnail shown in the list followed by the driver games. Note that the session is selected by default.
Select (hightlight) the Game you want to load and then Left Click on the DRIVE SESSION button.

This will load the saved Game, the session and the route into Driver. |
 |
If you load a Game after you have edited the original route or session that was used to create it, then you will receive a message warning you that changes have been made to the original assets. The changes could affect the operation of the Game.
 |
If you have opened the Game in Driver directly from Content Manager then you will not be given this warning |
|
| |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
Options:-
 |
Cancel - the Game will NOT be loaded, OR |
 |
Ok - load the Game wirh the changes |
If the changes to the route or session have been:-
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
minor and non-operational, such as scenery assets (trees, buildings, etc) then the Game can be safely loaded. |
| Error creating thumbnail: /bin/bash: line 1: /usr/bin/convert: No such file or directory Error code: 127 |
more significant operational changes, such as triggers, trackmarks, active industries, consists, tracks, etc, then it may NOT be wise to load and run the Game. |
Only you can be the judge but I would err on the side of caution
|
|
|
Editing Games
|
 |
 |
|
|
|
|
| You can edit a saved Game using the UDS (Unified Driver Surveyor) interface. However:-
In both cases the changes you make will appear in the Game when you use the UDS to return to Driver and will be part of the Game when you next save.
|
| Steps: To Edit a Game:- |
 |
Use the UDS to switch from Driver to Surveyor. The game will be immediately paused so that nothing will be moving while you are in Surveyor (do not switch OFF the Pause function) |
 |
Edit the Route and/or Session as you normally would in Surveyor. Save if you want to make the changes permanent |
 |
Use the UDS to switch back to Driver. Press the P key to cancel the Pause and resume game play |
|
 |
Deleting a Route will delete that Route, all its Sessions and all its saved Games (if any) |
 |
Deleting a Session will delete that Session and its saved Games (if any). It will NOT delete the Route it was created from. It will NOT delete other Sessions created for that Route. It will NOT delete any other Games created for those other Sessions |
 |
Deleting a Game will only delete that Game. It will NOT delete the Route or Session it was created from or any other Games from that Session |
| All the Surveyor and Driver screens for loading routes and sessions have a DELETE ... button as an option. |
| |
WARNING: |
 |
If you delete a Route you will also delete all the Sessions and Games created using that Route
|
 |
If you delete a Session you will also delete all the Games created using that Session
|
|
If you need a more selective way of deleting routes, sessions and driver games, then use Content Manager from the Trainz Launch Screen. Select the Filter Routes & Sessions.

The Type column will identify each entry as a route, session or Misc. Misc in this case means a saved Game.
You can delete routes and/or sessions individually but if you delete a route by itself then its dependant sessions and driver games will be shown as faulty with Missing dependencies. Likewise, if you delete a session by itself then its dependant driver games will be shown as faulty with Missing dependencies. |
Trainz Wiki
 |
Route and Session Building Guides
|
| |
More Tutorials and Guides to Using Trainz
|
|
 |
Related Links
|
|
This page was created by Trainz user pware in September 2021 and was last updated as shown below.